
Create a personal geodatabase 
To create a personal geodatabase that corresponds to the same release as the ArcGIS for Desktop 

client you are using, follow these steps: 

1. In ArcCatalog, right-click the file folder in the Catalog tree where you want to create the new 

personal geodatabase. 

2. Point to New. 

3. Click Personal Geodatabase. 

A personal geodatabase is created in the location you selected. 

 

 

 

 

 

 

 

 

 

4. Type a new name (My Personal GDB) for this personal geodatabase and press Enter. 

 

  



Create a file geodatabase 

From a folder connection 

Follow these steps to create a file geodatabase in a folder from ArcGIS for Desktop: 

1. Right-click the folder where you want to create the file geodatabase, point to New, and click File 

Geodatabase. 

A file geodatabase is created in the location you selected. 

2. Type a new name (My File GDB) for this personal geodatabase and press Enter. 

 

 



Run the Create File GDB tool 

The Create File GDB geoprocessing tool allows you to create a file geodatabase that corresponds 

to an older release of ArcGIS. This allows you to share data with people who have older releases 

of ArcGIS, which may not be able to open newer releases of the geodatabase. 

1. Open the Create File GDB in ArcGIS for Desktop. 

You can use the search to find the tool or open it directly from the Workspace toolset of the Data 

Management toolbox. 

 

 

 

 

 

 

 

 

 



 

2. Specify the folder location where you want the file geodatabase created. 

3. Type a name (My File GDB V10) for the geodatabase. 

4. Choose which ArcGIS version you want the file geodatabase to be. 

The functionality available in the geodatabase will be limited to the release you choose. 

5. Click OK to run the tool. 

A file geodatabase is created in the location you specified. 

 

 

 

 

 



Create an enterprise geodatabase 
You can create a database, geodatabase administrator, and enterprise geodatabase in a Microsoft 

SQL Server using the Create Enterprise Geodatabase geoprocessing tool.  

Requirements 

 You have SQL Server installed and the instance configured 

 You perform the role of both the database administrator and geodatabase administrator and, 
therefore, know the password for both logins 

 You need an ArcGIS Server keycodes file to authorize your geodatabase 
 

Run the Create Enterprise Geodatabase tool 

If you have access to ArcGIS for Desktop, you can run a geoprocessing tool to create the 

geodatabase. 

1. Start ArcCatalog. 

2. Search and open the Create Enterprise Geodatabase tool. 

 

 



3. Choose SQL Server from the Database Platform drop-down list. 

4. Type the name of the SQL Server instance to which you will connect in the Instance text box. 

5. In the Database text box, type the name of the database where you want to store your geodatabase. 

If a database with that name does not already exist in the SQL Server instance, it will be created. If it 

already exists, the database you specify will be used to store the geodatabase. 

6. Connect to SQL Server as a system administrator. This can be done with either an operating system-

authenticated login that is a member of the sysadmin fixed server role in SQL Server or by typing a 

database user name and password for a sysadmin user. 

o To log in with a sysadmin operating system-authenticated login, check Operating System 

Authentication. You must be logged in to Windows with the correct login to use this option. 

o To log in as sysadmin, type the sysadmin user name in the Database Administrator text box 

and the corresponding password in the Database Administrator Password text box. 

7. Choose the schema that will contain the geodatabase: 

o If you want the user named sde to be the geodatabase administrator and the geodatabase 

to be stored in the sde user's schema, check Sde Owned Schema. 

o If you want the dbo user to be the geodatabase administrator and the geodatabase to be 

stored in the dbo schema, uncheck Sde Owned Schema. 

For more information on storing the geodatabase in either the sde or dbo schema, see A comparison of 

geodatabase owners in SQL Server. 

If you choose an sde-owned schema, the Geodatabase Administrator text box will be prepopulated 

with sde. If a user with that name does not already exist, the user and its corresponding schema will be 

created, and the user will be granted the privileges required to create a geodatabase. 

If you are using database authentication and a dbo schema to store the geodatabase, type the name of a 

user who is dbo in the SQL Server instance in the Geodatabase Administrator text box. 

If you are using operating system authentication to connect to the database, your current login must be 

in the SQL Server sysadmin fixed-server role to create a dbo-schema geodatabase. 



8. Type a password for the geodatabase administrator in the Geodatabase Administrator 

Password text box. 

If the geodatabase administrator you specified already exists in the database, be sure to type the 

correct password for the existing user; this tool will not change the password. 

9. To specify an Authorization File, browse to and choose the keycodes file that was created when you 

authorized ArcGIS for Server Enterprise. 

This file is written to the \\Program Files\ESRI\License<release#>\sysgen folder on 

Windows servers. If you have not already done so, authorize ArcGIS for Server now to create this file. 

10. Click OK to run the tool. 

A database and log files are created in the default SQL Server location if you did not specify an 

existing database. A geodatabase is created in the database. If you chose an sde-schema 

geodatabase, a SQL Server-authenticated sde login, database user, and schema are created. 

A log file for the geodatabase creation (GDBCreateGeodatabase<#>.log) is written to the 

directory specified for your %TEMP% variable on the computer where the tool is run. If you 

have any problems running the tool, check this log file to troubleshoot the problem. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Importing feature classes 
 

Importing feature class (single) 

1. In the Catalog tree, right-click the geodatabase or feature dataset to which you want to import 

a dataset. Click Import > Feature Class (single). 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



2. Set required parameters for Feature Class To Feature Class tool  
 

 
 

3. Click OK 

 

 

This creates a new feature class in the file geodatabase.  
 
 
 

 
 
 
 



Importing feature class (multiple) 

1. In the Catalog tree, right-click the geodatabase or feature dataset to which you want to 

import a dataset. Click Import > Feature Class (multiple). 

 

 
 
 
 
 

2. Set required parameters for Feature Class To Feature Class tool  

 
 



 
 
 

3. Click OK 

 

This creates a new feature classes in the file geodatabase.  



Importing table (single) 

1. In the Catalog tree, right-click the geodatabase or feature dataset to which you want to 

import a dataset. Click Import > Table (single). 

 

 
 

 

 

 

 

2. Set required parameters for Table to Table tool  



 

 

 

 

3. Click OK 
 

This creates a new table in the file geodatabase.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

Designing Maps in ArcMap 

Setting map document properties 

You can define how path references are maintained in your document by checking or 

unchecking Store relative pathnames to data source. If this box is checked, paths are stored as 

incomplete paths that are relative to the current location of this document on disk. Using relative 

paths makes the map document more easily portable because ArcGIS will resolve the paths to the 

document's data sources relative to the document's current location in the file system rather than by 

full paths that include a drive letter or machine name. 

 

1. Click File > Map Document Properties. 

 

 
 
 

4. Set required parameters for Map Document Properties window. Setting default geodatabase 

and checking the ‘Store relative pathnames to data sources’ are very important.  

 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Adding map layers 

Adding a dataset 

Using the Add Data button—Click the Add Data button  and navigate to the desired dataset. Then 

select and add it to your map. 

 

 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Dragging a dataset from ArcCatalog—You can add data to your map from the ArcCatalog application. 

In ArcCatalog, navigate to the desired dataset. Then select and drag it onto the ArcMap data frame. 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Adding x,y coordinate data as a layer 

1. Click File > Add Data > Add XY Data. 

 

 

2. Select the table that contains x,y coordinate data. 

3. Identify the columns that hold the x- and y-coordinates (and, optionally, the z-coordinate). 

4. Specify the coordinate system. 

 



 

 

5. Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 



Saving an x,y layer as a feature class 

You can save the contents of an x,y layer as a feature class using the following steps: 

1. Right-click the x,y layer name and click Data > Export Data. The Export Data dialog box 

opens. 

 

2. Set the output coordinate system and specify the location and name of the new feature class. 



 

3. Click OK to save the new feature class. 

 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 



Editing existing features 

Adding new features  

Adding new feature 

Task: create new cafés in the map. 

1. In ArcMap, activate the Editor toolbar by clicking on icon on standard toolbar. 

 

2. Select Start Editing from the list in the ‘Editor’ drop-down menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://desktop.arcgis.com/en/arcmap/latest/manage-data/editing/a-quick-tour-of-editing.htm


3. Click on Create Features icon on Editor toolbar to open the Create Features window.  

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Select ‘Café’ from the list on the Create Features window.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

5. Click on the map to add new Café.  

 

6. Click on Attributes icon on Editor toolbar to open the Attributes window.  

 

This will allow you to edit attributes of the café while creating it.  

 

 

 

 

 

 

7. Type name for the newly created Café. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Select Stop Editing from the list in the ‘Editor’ drop-down menu. 

 

9. Click Yes on the Save dialog box. 

 

 

 

 



Deleting features  

Task: delete few buildings from the map. 

1. Select Start Editing from the list in the ‘Editor’ drop-down menu. 

2. Click on Edit Tool icon on Editor toolbar, which allows you to select features. 

 

 

 

 

 

 

 

 

 

 

3. Click on a building feature to select it. 

The selected feature will be highlighted in light blue color as well as marked with ‘X’ .  

  

 

4. Right click on the selected feature or select Delete under the Edit menu to delete the feature.  



Splitting and merging polygon and line features 

Splitting a line feature 

1. Select Start Editing from the list in the ‘Editor’ drop-down menu. 

2. Click on Edit Tool icon on Editor toolbar, which allows you to select features. 

3. Select the line that you want to split. 

The selected feature will be highlighted in light blue color as well as marked with ‘X’ . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



4. Click on Split Tool icon on Editor toolbar  

The cursor changed to ‘+’ . 

 

 

 

 

 

 

 

5. Click on the selected line where you want to split. 

 

Merging polygon features 

1. Select Start Editing from the list in the ‘Editor’ drop-down menu. 

2. Click on Edit Tool icon on Editor toolbar, which allows you to select features. 

3. Select more than one polygon features that you want to merge using the Edit Tool while holding 

Shift key on the keyboard.  

The selected feature will be highlighted in light blue color as well as marked with ‘X’ . 



 

2. Select Merge… from the list in the ‘Editor’ drop-down menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Choose the feature with which other feature will be merged on the ‘Merge’ dialog box. 

 

 

 

 

 

 

 

 

 

4. Click OK 

 

 

 



 

Editing attributes 

Editing attributes in the Attributes window 

The Attributes window allows you to view and edit attributes of features you have selected.  

Note: You must turn of Start Editing to be able to edit attributes of a feature.  

1. Open it by clicking the Attributes button  on the Editor toolbar. 

 

 

 

 

 

 

 

 

2. Using the Edit Tool           click on the feature that you want to edit its attribute.  

This selects a feature and loads all attribute information in the Attributes window.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

All attribute values can be modified except the 

FID. 
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Editing attributes in the table window 

Once you begin an edit session, you'll notice a pencil icon next to the Show Selected Records icon 

on the Table window, indicating that the table can be edited. In addition, those fields that you can 

edit will have a white background in the field heading. You can make any of the attribute changes 

you need by clicking a cell and typing a new attribute value. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

Table join 

Joining the attributes from a table 

Join appends the attributes from one table onto the other based on a field common to both.  

Typically, you'll join a table of data to a layer based on the value of a field that can be found in both 

tables. The name of the field does not have to be the same, but the data type has to be the same; 

you join numbers to numbers, strings to strings, and so on. 

Task: add an attribute of area in meter square for buildings in the ‘SampleData_Buildings’ feature 

class. 

1. Add the table that you want to join to the layer to ArcMap. 

Add MaputoBuildings_Data worksheet of the MaputoBuildings_Area.xls into ArcMap.  

2. Right click on SampleData_Buildings 

layer. 

3. Select Joins and Relates > Join…  

from the drop down menue 

4. Set required parameters for the Join 

Data tool 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

5. Click OK 

All attribute fields of the joined table will be added to the table of this layer.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Creating a map package 
Map packages (.mpk) make it easy to share complete map documents with others. A map package 

contains a map document (.mxd) and the data referenced by the layers it contains, packaged into 

one convenient, portable file. Map packages can be used for easy sharing of maps between 

colleagues in a work group, across departments in an organization, or with any other ArcGIS users 

via ArcGIS Online.  

 

1. Click File > Share As > Map Package on the main menu. The Map Package dialog box 

appears: 

 

2. Name your new map package. 

3. Specify where to save your map package. 



4. Fill in the required fields for Item Description. 

5. Click Analyze to validate your map for any errors or issues.  

You must validate and resolve all errors before you can save it to disk or share it to ArcGIS Online.  

 



6. Once validated, click Share  to create your map package. 

 

 

 

 

 

 

 

 

 

 

 

7. Click OK 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Publishing data for web GIS? 
 

 


